xml地图|网站地图|网站标签 [设为首页] [加入收藏]

软件资讯

当前位置:美高梅游戏网站 > 软件资讯 > 有关eclipse项目出现的部分主题材料消除办法

有关eclipse项目出现的部分主题材料消除办法

来源:http://www.gd-chuangmei.com 作者:美高梅游戏网站 时间:2019-09-05 04:58

安装了oracle10g的客户端后,eclipse打不开了。所以检查了一下,发现是以下原因。
运行eclipse出现以下错误: Incompatible JVM
Version 1.3.1_美高梅游戏官网娱乐,01 of the JVM is not suitable for this product.Version:1.4.1 or greater is required.
美高梅棋牌,或 美高梅游戏网站,Version 1.4.1_02 of the JVM is not suitable for this product.Version:1.5 or greater is required.

1、项目中出现红色叉但是找不到出错的文件

美高梅棋牌 1

有这种错误让人很恼火,因为并不知道是哪个文件引起的整个项目错误。所以我们可以打开下边的错误按钮,看看是什么问题。

一,系统上的JAVA JDK版本过低,去装高版本的JDK.
二,这个是最有可能是装了oracle了,因为oracle是使用1.3JVM的而eclipse是需要1.4或1.5以上JVM的。
解决方法:
就是在环境变量中把JDK的的路径放到Oracle JDK的前面就可以解决

如果是因为java compiler level does not match the version of the installed java,

运行eclipse出现以下错误: Incompatible JVM Version 1.3.1_01 of the...

那么我们打开项目的properties,有一个选项为project facets,

点击打开,在右边选择Java版本为最新的,然后apply,应该就ok了。

 

当然也有可能是因为引用的jar包无效而导致的,根据指出的哪个jar删除进行重新引用即可。

 

2、Eclipse升级JDK版本时遇到的问题

本文由美高梅游戏网站发布于软件资讯,转载请注明出处:有关eclipse项目出现的部分主题材料消除办法

关键词:

上一篇:字符串增添空格和去除空格方法

下一篇:没有了